What’s Vulnerable › Vulnerabilities
CVE-2021-29754
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-11 · updated 2026-06-17
Description
IBM WebSphere Application Server 7.0, 8.0, 8.5, and 9.0 is vulnerable to a privilege escalation vulnerability when using the SAML Web Inbound Trust Association Interceptor (TAI). IBM X-Force ID: 202006.
Affected products
- IBM WebSphere Application Server: from 7.0.0.0 before 7.0.0.45; from 8.0.0.0 before 8.0.0.15; from 8.5.0.0 before 8.5.5.20; from 9.0.0.0 before 9.0.5.8 — fixed in 7.0.0.45, 8.0.0.15, 8.5.5.20, 9.0.5.8
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 7.0.0.45, 8.0.0.15, 8.5.5.20, 9.0.5.8. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/202006
- https://www.ibm.com/support/pages/node/6462627
- https://exchange.xforce.ibmcloud.com/vulnerabilities/202006
- https://www.ibm.com/support/pages/node/6462627
Get alerted when CVE-2021-29754 or the next vulnerability affects your stack