What’s Vulnerable › Vulnerabilities
CVE-2021-29843
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-08 · updated 2026-06-17
Description
IBM MQ 9.1 LTS, 9.1 CD, 9.2 LTS, and 9.2CD is vulnerable to a denial of service attack caused by an issue processing message properties. IBM X-Force ID: 205203.
Affected products
- IBM MQ Appliance: from 9.1.0.0 before 9.1.0.9; from 9.1.0.0 before 9.2.3; from 9.2.0.0 before 9.2.0.3 — fixed in 9.1.0.9, 9.2.0.3, 9.2.3
How to fix
Upgrade to a fixed version: IBM MQ Appliance 9.1.0.9, 9.2.0.3, 9.2.3. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/205203
- https://www.ibm.com/support/pages/node/6513681
- https://exchange.xforce.ibmcloud.com/vulnerabilities/205203
- https://www.ibm.com/support/pages/node/6513681
Get alerted when CVE-2021-29843 or the next vulnerability affects your stack