What’s Vulnerable › Vulnerabilities
CVE-2021-29961
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-24 · updated 2026-06-17
- Weakness: CWE-863
Description
When styling and rendering an oversized `<select>` element, Firefox did not apply correct clipping which allowed an attacker to paint over the user interface. This vulnerability affects Firefox < 89.
Affected products
- Mozilla Firefox: from 78.11.0 before 89.0 — fixed in 89.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 89.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1700235
- https://security.gentoo.org/glsa/202107-09
- https://www.mozilla.org/security/advisories/mfsa2021-23/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1700235
- https://security.gentoo.org/glsa/202107-09
- https://www.mozilla.org/security/advisories/mfsa2021-23/
Get alerted when CVE-2021-29961 or the next vulnerability affects your stack