What’s Vulnerable › Vulnerabilities
CVE-2021-29970
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-05 · updated 2026-06-17
- Weakness: CWE-416
Description
A malicious webpage could have triggered a use-after-free, memory corruption, and a potentially exploitable crash. *This bug could only be triggered when accessibility was enabled.*. This vulnerability affects Thunderbird < 78.12, Firefox ESR < 78.12, and Firefox < 90.
Affected products
- Mozilla Firefox: before 90.0 — fixed in 90.0
- Mozilla Firefox ESR: before 78.12 — fixed in 78.12
- Mozilla Thunderbird: before 78.12 — fixed in 78.12
How to fix
Upgrade to a fixed version: Mozilla Firefox 90.0; Mozilla Firefox ESR 78.12; Mozilla Thunderbird 78.12. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1709976
- https://security.gentoo.org/glsa/202202-03
- https://security.gentoo.org/glsa/202208-14
- https://www.mozilla.org/security/advisories/mfsa2021-28/
- https://www.mozilla.org/security/advisories/mfsa2021-29/
- https://www.mozilla.org/security/advisories/mfsa2021-30/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1709976
- https://security.gentoo.org/glsa/202202-03
- https://security.gentoo.org/glsa/202208-14
- https://www.mozilla.org/security/advisories/mfsa2021-28/
- https://www.mozilla.org/security/advisories/mfsa2021-29/
- https://www.mozilla.org/security/advisories/mfsa2021-30/
Get alerted when CVE-2021-29970 or the next vulnerability affects your stack