What’s Vulnerable › Vulnerabilities
CVE-2021-29988
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-17 · updated 2026-06-17
- Weakness: CWE-125
Description
Firefox incorrectly treated an inline list-item element as a block element, resulting in an out of bounds read or memory corruption, and a potentially exploitable crash. This vulnerability affects Thunderbird < 78.13, Thunderbird < 91, Firefox ESR < 78.13, and Firefox < 91.
Affected products
- Mozilla Firefox: before 91.0 — fixed in 91.0
- Mozilla Firefox ESR: before 78.13.0 — fixed in 78.13.0
- Mozilla Thunderbird: before 78.13.0 — fixed in 78.13.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 91.0; Mozilla Firefox ESR 78.13.0; Mozilla Thunderbird 78.13.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1717922
- https://security.gentoo.org/glsa/202202-03
- https://security.gentoo.org/glsa/202208-14
- https://www.mozilla.org/security/advisories/mfsa2021-33/
- https://www.mozilla.org/security/advisories/mfsa2021-34/
- https://www.mozilla.org/security/advisories/mfsa2021-35/
- https://www.mozilla.org/security/advisories/mfsa2021-36/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1717922
- https://security.gentoo.org/glsa/202202-03
- https://security.gentoo.org/glsa/202208-14
- https://www.mozilla.org/security/advisories/mfsa2021-33/
- https://www.mozilla.org/security/advisories/mfsa2021-34/
Get alerted when CVE-2021-29988 or the next vulnerability affects your stack