What’s Vulnerable › Vulnerabilities
CVE-2021-30055
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-05 · updated 2026-06-17
- Weakness: CWE-89
Description
A SQL injection vulnerability in Knowage Suite version 7.1 exists in the documentexecution/url analytics driver component via the 'par_year' parameter when running a report.
Affected products
- KnowageLabs Knowage-Server: before 7.4 — fixed in 7.4
How to fix
Upgrade to a fixed version: KnowageLabs Knowage-Server 7.4. Check the vendor advisory for mitigations.
References
- https://github.com/piuppi/Proof-of-Concepts/blob/main/Engineering/SQLi-KnowageSuite.md
- https://github.com/piuppi/Proof-of-Concepts/blob/main/Engineering/SQLi-KnowageSuite.md
Get alerted when CVE-2021-30055 or the next vulnerability affects your stack