What’s Vulnerable › Vulnerabilities
CVE-2021-30056
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Knowage Suite before 7.4 is vulnerable to reflected cross-site scripting (XSS). An attacker can inject arbitrary web script in /restful-services/publish via the 'EXEC_FROM' parameter that can lead to data leakage.
Affected products
- KnowageLabs Knowage-Server: before 7.4 — fixed in 7.4
How to fix
Upgrade to a fixed version: KnowageLabs Knowage-Server 7.4. Check the vendor advisory for mitigations.
References
- https://github.com/piuppi/Proof-of-Concepts/blob/main/Engineering/XSS-KnowageSuite.md
- https://github.com/piuppi/Proof-of-Concepts/blob/main/Engineering/XSS-KnowageSuite.md
Get alerted when CVE-2021-30056 or the next vulnerability affects your stack