What’s Vulnerable › Vulnerabilities
CVE-2021-30070
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-18 · updated 2026-06-17
Description
An issue was discovered in HestiaCP before v1.3.5. Attackers are able to arbitrarily install packages due to values taken from the pgk [] parameter in the update request being transmitted to the operating system's package manager.
Affected products
- hestiacp/hestiacp: before 1.3.5 — fixed in 1.3.5
How to fix
Upgrade to a fixed version: hestiacp/hestiacp 1.3.5. Check the vendor advisory for mitigations.
References
- https://github.com/hestiacp/hestiacp/commit/27556a9a43aeaf308b33be224c2e70f2011574e6
- https://github.com/hestiacp/hestiacp/commit/9a1fccd37f2842fdf96ffb48895c4bfa9788c469
- https://github.com/hestiacp/hestiacp/commit/27556a9a43aeaf308b33be224c2e70f2011574e6
- https://github.com/hestiacp/hestiacp/commit/9a1fccd37f2842fdf96ffb48895c4bfa9788c469
Get alerted when CVE-2021-30070 or the next vulnerability affects your stack