What’s Vulnerable › Vulnerabilities
CVE-2021-30130: Improper Certificate Validation in phpseclib
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-06 · updated 2026-06-17
- Weakness: CWE-347
Description
phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.
Affected products
- Debian Linux: 10.0
- phpseclib: before 2.0.31; from 3.0 before 3.0.7 — fixed in 2.0.31, 3.0.7
- Packagist Phpseclib/Phpseclib: from 3.0.0 before 3.0.7; before 2.0.31; 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5 (+71) — fixed in 3.0.7, 2.0.31
How to fix
Upgrade to a fixed version: phpseclib 2.0.31, 3.0.7; Packagist Phpseclib/Phpseclib 3.0.7, 2.0.31. Check the vendor advisory for mitigations.
References
- https://github.com/phpseclib/phpseclib/pull/1635
- https://github.com/phpseclib/phpseclib/releases/tag/2.0.31
- https://github.com/phpseclib/phpseclib/releases/tag/3.0.7
- https://lists.debian.org/debian-lts-announce/2022/11/msg00024.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00025.html
- https://github.com/phpseclib/phpseclib/pull/1635
- https://github.com/phpseclib/phpseclib/releases/tag/2.0.31
- https://github.com/phpseclib/phpseclib/releases/tag/3.0.7
- https://lists.debian.org/debian-lts-announce/2022/11/msg00024.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00025.html
Get alerted when CVE-2021-30130 or the next vulnerability affects your stack