What’s Vulnerable › Vulnerabilities
CVE-2021-30139
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-21 · updated 2026-06-17
- Weakness: CWE-125
Description
In Alpine Linux apk-tools before 2.12.5, the tarball parser allows a buffer overflow and crash.
Affected products
- Alpinelinux Apk-Tools: before 2.10.6; from 2.12.0 before 2.12.5 — fixed in 2.10.6, 2.12.5
How to fix
Upgrade to a fixed version: Alpinelinux Apk-Tools 2.10.6, 2.12.5. Check the vendor advisory for mitigations.
References
- https://gitlab.alpinelinux.org/alpine/apk-tools/-/issues/10741
- https://gitlab.alpinelinux.org/alpine/aports/-/issues/12606
- https://gitlab.alpinelinux.org/alpine/apk-tools/-/issues/10741
- https://gitlab.alpinelinux.org/alpine/aports/-/issues/12606
Get alerted when CVE-2021-30139 or the next vulnerability affects your stack