What’s Vulnerable › Vulnerabilities
CVE-2021-30164
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-06 · updated 2026-06-17
Description
Redmine before 4.0.8 and 4.1.x before 4.1.2 allows attackers to bypass the add_issue_notes permission requirement by leveraging the Issues API.
Affected products
- Debian Linux: 9.0
- Redmine: before 4.0.8; from 4.1.0 before 4.1.2 — fixed in 4.0.8, 4.1.2
How to fix
Upgrade to a fixed version: Redmine 4.0.8, 4.1.2. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2021/05/msg00013.html
- https://www.redmine.org/projects/redmine/wiki/Security_Advisories
- https://lists.debian.org/debian-lts-announce/2021/05/msg00013.html
- https://www.redmine.org/projects/redmine/wiki/Security_Advisories
Get alerted when CVE-2021-30164 or the next vulnerability affects your stack