What’s Vulnerable › Vulnerabilities
CVE-2021-30181: Apache Dubbo RCE on customers via Script route poisoning (Nashorn script injection)
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 60.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-01 · updated 2026-06-17
Description
Apache Dubbo prior to 2.6.9 and 2.7.9 supports Script routing which will enable a customer to route the request to the right server. These rules are used by the customers when making a request in order to find the right endpoint. When parsing these rules, Dubbo customers use ScriptEngine and run the rule provided by the script which by default may enable executing arbitrary code.
Affected products
- Apache Software Foundation Apache Dubbo: from 2.5.0 before 2.6.10; from 2.7.0 before 2.7.10 — fixed in 2.6.10, 2.7.10
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Dubbo 2.6.10, 2.7.10. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/re22410dc704a09bc7032ddf15140cf5e7df3e8ece390fc9032ff5587%40%3Cdev.dubbo.apache.org%3E
- https://lists.apache.org/thread.html/re22410dc704a09bc7032ddf15140cf5e7df3e8ece390fc9032ff5587%40%3Cdev.dubbo.apache.org%3E
Get alerted when CVE-2021-30181 or the next vulnerability affects your stack