What’s Vulnerable › Vulnerabilities
CVE-2021-3043: Prisma Cloud: Cross-Site Scripting (XSS) Vulnerability in Prisma Cloud Compute Web Console
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-15 · updated 2026-06-17
- Weakness: CWE-79
Description
A reflected cross-site scripting (XSS) vulnerability exists in the Prisma Cloud Compute web console that enables a remote attacker to execute arbitrary JavaScript code in the browser-based web console while an authenticated administrator is using that web interface. Prisma Cloud Compute SaaS versions were automatically upgraded to the fixed release. No additional action is required for these instances. This issue impacts: Prisma Cloud Compute 20.12 versions earlier than Prisma Cloud Compute 20.12.552; Prisma Cloud Compute 21.04 versions earlier than Prisma Cloud Compute 21.04.439.
Affected products
- Palo Alto Networks Prisma Cloud Compute: from 20.12 before 20.12.552; from 21.04 before 21.04.439 — fixed in 20.12.552, 21.04.439
- Palo Alto Networks Prisma Cloud Compute: from 21.04 before 21.04.439; from 20.12 before 20.12.552 — fixed in 21.04.439, 20.12.552
How to fix
Upgrade to a fixed version: Palo Alto Networks Prisma Cloud Compute 20.12.552, 21.04.439; Palo Alto Networks Prisma Cloud Compute 21.04.439, 20.12.552. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2021-3043
- https://security.paloaltonetworks.com/CVE-2021-3043
Get alerted when CVE-2021-3043 or the next vulnerability affects your stack