What’s Vulnerable › Vulnerabilities

CVE-2021-30458

Description

An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2. An attacker can send crafted wikitext that Utils/WTUtils.php will transform by using a <meta> tag, bypassing sanitization steps, and potentially allowing for XSS.

Affected products

How to fix

Upgrade to a fixed version: Wikimedia Parsoid 0.11.1, 0.12.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-30458 or the next vulnerability affects your stack