What’s Vulnerable › Vulnerabilities
CVE-2021-3046: PAN-OS: Improper SAML Authentication Vulnerability in GlobalProtect Portal
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-11 · updated 2026-06-17
- Weakness: CWE-287
Description
An improper authentication vulnerability exists in Palo Alto Networks PAN-OS software that enables a SAML authenticated attacker to impersonate any other user in the GlobalProtect Portal and GlobalProtect Gateway when they are configured to use SAML authentication. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.19; PAN-OS 9.0 versions earlier than PAN-OS 9.0.14; PAN-OS 9.1 versions earlier than PAN-OS 9.1.9; PAN-OS 10.0 versions earlier than PAN-OS 10.0.5. PAN-OS 10.1 versions are not impacted.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.19; from 9.0.0 before 9.0.14; from 9.1.0 before 9.1.9; from 10.0.0 before 10.0.5 — fixed in 8.1.19, 9.0.14, 9.1.9, 10.0.5
- Palo Alto Networks PAN-OS: from 8.1 before 8.1.19; from 9.0 before 9.0.14; from 9.1 before 9.1.9; from 10.0 before 10.0.5 — fixed in 8.1.19, 9.0.14, 9.1.9, 10.0.5
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.19, 9.0.14, 9.1.9, 10.0.5; Palo Alto Networks PAN-OS 8.1.19, 9.0.14, 9.1.9, 10.0.5. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2021-3046
- https://security.paloaltonetworks.com/CVE-2021-3046
Get alerted when CVE-2021-3046 or the next vulnerability affects your stack