What’s Vulnerable › Vulnerabilities
CVE-2021-3047: PAN-OS: Weak Cryptography Used in Web Interface Authentication
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-11 · updated 2026-06-17
- Weakness: CWE-338
Description
A cryptographically weak pseudo-random number generator (PRNG) is used during authentication to the Palo Alto Networks PAN-OS web interface. This enables an authenticated attacker, with the capability to observe their own authentication secrets over a long duration on the PAN-OS appliance, to impersonate another authenticated web interface administrator's session. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.19; PAN-OS 9.0 versions earlier than PAN-OS 9.0.14; PAN-OS 9.1 versions earlier than PAN-OS 9.1.10; PAN-OS 10.0 versions earlier than PAN-OS 10.0.4. PAN-OS 10.1 versions are not impacted.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.19; from 9.0.0 before 9.0.14; from 9.1.0 before 9.1.10; from 10.0.0 before 10.0.4 — fixed in 8.1.19, 9.0.14, 9.1.10, 10.0.4
- Palo Alto Networks PAN-OS: from 8.1 before 8.1.19; from 9.0 before 9.0.14; from 10.0 before 10.0.4; from 9.1 before 9.1.10 — fixed in 8.1.19, 9.0.14, 10.0.4, 9.1.10
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.19, 9.0.14, 9.1.10, 10.0.4; Palo Alto Networks PAN-OS 8.1.19, 9.0.14, 10.0.4, 9.1.10. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2021-3047
- https://security.paloaltonetworks.com/CVE-2021-3047
Get alerted when CVE-2021-3047 or the next vulnerability affects your stack