What’s Vulnerable › Vulnerabilities
CVE-2021-3050: PAN-OS: OS Command Injection Vulnerability in Web Interface
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-11 · updated 2026-06-17
- Weakness: CWE-78
Description
An OS command injection vulnerability in the Palo Alto Networks PAN-OS web interface enables an authenticated administrator to execute arbitrary OS commands to escalate privileges. This issue impacts: PAN-OS 9.0 version 9.0.10 through PAN-OS 9.0.14; PAN-OS 9.1 version 9.1.4 through PAN-OS 9.1.10; PAN-OS 10.0 version 10.0.7 and earlier PAN-OS 10.0 versions; PAN-OS 10.1 version 10.1.0 through PAN-OS 10.1.1. Prisma Access firewalls and firewalls running PAN-OS 8.1 versions are not impacted by this issue.
Affected products
- Palo Alto Networks PAN-OS: from 9.0.0 before 9.0.15; from 9.1.0 before 9.1.11; from 10.0.0 before 10.0.8; from 10.1.0 before 10.1.2 — fixed in 9.0.15, 9.1.11, 10.0.8, 10.1.2
- Palo Alto Networks PAN-OS: 9.0.x from 9.0.10; 9.1.x from 9.1.4; 10.0.x from 10.0.0; 10.1.x from 10.1.0 — fixed in 9.0.15, 9.1.11, 10.0.8, 10.1.2
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 9.0.15, 9.1.11, 10.0.8, 10.1.2; Palo Alto Networks PAN-OS 9.0.15, 9.1.11, 10.0.8, 10.1.2. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2021-3050
- https://security.paloaltonetworks.com/CVE-2021-3050
Get alerted when CVE-2021-3050 or the next vulnerability affects your stack