What’s Vulnerable › Vulnerabilities
CVE-2021-30509
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-04 · updated 2026-06-17
- Weakness: CWE-787
Description
Out of bounds write in Tab Strip in Google Chrome prior to 90.0.4430.212 allowed an attacker who convinced a user to install a malicious extension to perform an out of bounds memory write via a crafted HTML page and a crafted Chrome extension.
Affected products
- Fedoraproject Fedora: 33, 34
- Google Chrome: before 90.0.4430.212 — fixed in 90.0.4430.212
How to fix
Upgrade to a fixed version: Google Chrome 90.0.4430.212. Check the vendor advisory for mitigations.
References
- https://chromereleases.googleblog.com/2021/05/stable-channel-update-for-desktop.html
- https://crbug.com/1196309
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ETMZL6IHCTCTREEL434BQ4THQ7EOHJ43/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PAT6EOXVQFE6JFMFQF4IKAOUQSHMHL54/
- https://security.gentoo.org/glsa/202107-06
- https://chromereleases.googleblog.com/2021/05/stable-channel-update-for-desktop.html
- https://crbug.com/1196309
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ETMZL6IHCTCTREEL434BQ4THQ7EOHJ43/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PAT6EOXVQFE6JFMFQF4IKAOUQSHMHL54/
- https://security.gentoo.org/glsa/202107-06
Get alerted when CVE-2021-30509 or the next vulnerability affects your stack