What’s Vulnerable › Vulnerabilities

CVE-2021-3052: PAN-OS: Reflected Cross-Site Scripting (XSS) in Web Interface

Description

A reflected cross-site scripting (XSS) vulnerability in the Palo Alto Network PAN-OS web interface enables an authenticated network-based attacker to mislead another authenticated PAN-OS administrator to click on a specially crafted link that performs arbitrary actions in the PAN-OS web interface as the targeted authenticated administrator. This issue impacts: PAN-OS 8.1 versions earlier than 8.1.20; PAN-OS 9.0 versions earlier than 9.0.14; PAN-OS 9.1 versions earlier than 9.1.10; PAN-OS 10.0 versions earlier than 10.0.2. This issue does not affect Prisma Access.

Affected products

How to fix

Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.20, 9.0.14, 9.1.10, 10.0.2; Palo Alto Networks PAN-OS 9.0.14, 8.1.20, 9.1.10, 10.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-3052 or the next vulnerability affects your stack