What’s Vulnerable › Vulnerabilities
CVE-2021-3056: PAN-OS: Memory Corruption Vulnerability in GlobalProtect Clientless VPN During SAML Authentication
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-10 · updated 2026-06-17
- Weakness: CWE-120
Description
A memory corruption vulnerability in Palo Alto Networks PAN-OS GlobalProtect Clientless VPN enables an authenticated attacker to execute arbitrary code with root user privileges during SAML authentication. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.20; PAN-OS 9.0 versions earlier than PAN-OS 9.0.14; PAN-OS 9.1 versions earlier than PAN-OS 9.1.9; PAN-OS 10.0 versions earlier than PAN-OS 10.0.1. Prisma Access customers with Prisma Access 2.1 Preferred firewalls are impacted by this issue.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.20; from 9.0.0 before 9.0.14; from 9.1.0 before 9.1.9; 10.0.0 (and their updates) — fixed in 8.1.20, 9.0.14, 9.1.9
- Palo Alto Networks PAN-OS: from 9.0 before 9.0.14; from 8.1 before 8.1.20; from 9.1 before 9.1.9; from 10.0 before 10.0.1 — fixed in 9.0.14, 8.1.20, 9.1.9, 10.0.1
- Palo Alto Networks Prisma Access: 2.1 Preferred
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.20, 9.0.14, 9.1.9; Palo Alto Networks PAN-OS 9.0.14, 8.1.20, 9.1.9, 10.0.1. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2021-3056
- https://security.paloaltonetworks.com/CVE-2021-3056
Get alerted when CVE-2021-3056 or the next vulnerability affects your stack