What’s Vulnerable › Vulnerabilities
CVE-2021-30560: Nokogiri has vulnerable dependencies on libxml2 and libxslt
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-03 · updated 2026-06-17
- Weakness: CWE-416
Description
Use after free in Blink XSLT in Google Chrome prior to 91.0.4472.164 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
Affected products
- Debian Linux: 10.0, 11.0
- Google Chrome: before 91.0.4472.164 — fixed in 91.0.4472.164
- Splunk Universal Forwarder: from 8.2.0 before 8.2.12; from 9.0.0 before 9.0.6; 9.1.0 — fixed in 8.2.12, 9.0.6
- xmlsoft libxslt: before 1.1.35 — fixed in 1.1.35
- Rubygems Nokogiri: before 1.13.2; 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5 (+135) — fixed in 1.13.2
How to fix
Upgrade to a fixed version: Google Chrome 91.0.4472.164; Splunk Universal Forwarder 8.2.12, 9.0.6; xmlsoft libxslt 1.1.35; Rubygems Nokogiri 1.13.2. Check the vendor advisory for mitigations.
References
- https://chromereleases.googleblog.com/2021/07/stable-channel-update-for-desktop.html
- https://crbug.com/1219209
- https://lists.debian.org/debian-lts-announce/2022/09/msg00010.html
- https://security.gentoo.org/glsa/202310-23
- https://www.debian.org/security/2022/dsa-5216
- https://chromereleases.googleblog.com/2021/07/stable-channel-update-for-desktop.html
- https://crbug.com/1219209
- https://lists.debian.org/debian-lts-announce/2022/09/msg00010.html
- https://security.gentoo.org/glsa/202310-23
- https://www.debian.org/security/2022/dsa-5216
Get alerted when CVE-2021-30560 or the next vulnerability affects your stack