What’s Vulnerable › Vulnerabilities
CVE-2021-3057: GlobalProtect App: Buffer Overflow Vulnerability When Connecting to Portal or Gateway
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-13 · updated 2026-06-17
- Weakness: CWE-121
Description
A stack-based buffer overflow vulnerability exists in the Palo Alto Networks GlobalProtect app that enables a man-in-the-middle attacker to disrupt system processes and potentially execute arbitrary code with SYSTEM privileges. This issue impacts: GlobalProtect app 5.1 versions earlier than GlobalProtect app 5.1.9 on Windows; GlobalProtect app 5.2 versions earlier than GlobalProtect app 5.2.8 on Windows; GlobalProtect app 5.2 versions earlier than GlobalProtect app 5.2.8 on the Universal Windows Platform; GlobalProtect app 5.3 versions earlier than GlobalProtect app 5.3.1 on Linux.
Affected products
- Palo Alto Networks GlobalProtect App: from 5.0 through 5.0.8; from 5.0 through 5.0.9; from 5.0 through 5.0.10; from 5.1 through 5.1.1; from 5.1 before 5.1.9; from 5.1.0 through 5.1.4 — fixed in 5.1.9, 5.2.8, 5.3.1
- Palo Alto Networks GlobalProtect App: from 5.1 before 5.1.9; from 5.2 before 5.2.8 — fixed in 5.1.9, 5.2.8
How to fix
Upgrade to a fixed version: Palo Alto Networks GlobalProtect App 5.1.9, 5.2.8, 5.3.1; Palo Alto Networks GlobalProtect App 5.1.9, 5.2.8. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2021-3057
- https://security.paloaltonetworks.com/CVE-2021-3057
Get alerted when CVE-2021-3057 or the next vulnerability affects your stack