What’s Vulnerable › Vulnerabilities

CVE-2021-3058: PAN-OS: OS Command Injection Vulnerability in Web Interface XML API

Description

An OS command injection vulnerability in the Palo Alto Networks PAN-OS web interface enables an authenticated administrator with permissions to use XML API the ability to execute arbitrary OS commands to escalate privileges. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.20-h1; PAN-OS 9.0 versions earlier than PAN-OS 9.0.14-h3; PAN-OS 9.1 versions earlier than PAN-OS 9.1.11-h2; PAN-OS 10.0 versions earlier than PAN-OS 10.0.8; PAN-OS 10.1 versions earlier than PAN-OS 10.1.3. This issue does not impact Prisma Access firewalls.

Affected products

How to fix

Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.0.8, 10.1.3; Palo Alto Networks PAN-OS 10.1.3, 9.0.14-h3, 8.1.20-h1, 9.1.11-h2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-3058 or the next vulnerability affects your stack