What’s Vulnerable › Vulnerabilities
CVE-2021-3059: PAN-OS: OS Command Injection Vulnerability When Performing Dynamic Updates
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-10 · updated 2026-06-17
- Weakness: CWE-78
Description
An OS command injection vulnerability in the Palo Alto Networks PAN-OS management interface exists when performing dynamic updates. This vulnerability enables a man-in-the-middle attacker to execute arbitrary OS commands to escalate privileges. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.20-h1; PAN-OS 9.0 versions earlier than PAN-OS 9.0.14-h3; PAN-OS 9.1 versions earlier than PAN-OS 9.1.11-h2; PAN-OS 10.0 versions earlier than PAN-OS 10.0.8; PAN-OS 10.1 versions earlier than PAN-OS 10.1.3. Prisma Access customers that have Prisma Access 2.1 Preferred or Prisma Access 2.1 Innovation firewalls are impacted by this issue.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 through 8.1.20; from 9.0.0 through 9.0.14; from 9.1.0 through 9.1.11; from 10.0.0 before 10.0.8; from 10.1.0 before 10.1.3 — fixed in 10.0.8, 10.1.3
- Palo Alto Networks PAN-OS: from 10.0 before 10.0.8; from 10.1 before 10.1.3; from 8.1 before 8.1.20-h1; from 9.0 before 9.0.14-h3; from 9.1 before 9.1.11-h2 — fixed in 10.0.8, 10.1.3, 8.1.20-h1, 9.0.14-h3, 9.1.11-h2
- Palo Alto Networks Prisma Access: 2.1 Innovation, 2.1 Preferred
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.0.8, 10.1.3; Palo Alto Networks PAN-OS 10.0.8, 10.1.3, 8.1.20-h1, 9.0.14-h3. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2021-3059
- https://security.paloaltonetworks.com/CVE-2021-3059
Get alerted when CVE-2021-3059 or the next vulnerability affects your stack