What’s Vulnerable › Vulnerabilities
CVE-2021-3062: PAN-OS: Improper Access Control Vulnerability Exposing AWS Instance Metadata Endpoint to GlobalProtect Users
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-10 · updated 2026-06-17
- Weakness: CWE-284
Description
An improper access control vulnerability in PAN-OS software enables an attacker with authenticated access to GlobalProtect portals and gateways to connect to the EC2 instance metadata endpoint for VM-Series firewalls hosted on Amazon AWS. Exploitation of this vulnerability enables an attacker to perform any operations allowed by the EC2 role in AWS. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.20 VM-Series firewalls; PAN-OS 9.1 versions earlier than PAN-OS 9.1.11 VM-Series firewalls; PAN-OS 9.0 versions earlier than PAN-OS 9.0.14 VM-Series firewalls; PAN-OS 10.0 versions earlier than PAN-OS 10.0.8 VM-Series firewalls. Prisma Access customers are not impacted by this issue.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.20; from 9.0.0 before 9.0.14; from 9.1.0 before 9.1.11; from 10.0.0 before 10.0.8 — fixed in 8.1.20, 9.0.14, 9.1.11, 10.0.8
- Palo Alto Networks PAN-OS: from 9.1 before 9.1.11; from 8.1 before 8.1.20; from 9.0 before 9.0.14; from 10.0 before 10.0.8 — fixed in 9.1.11, 8.1.20, 9.0.14, 10.0.8
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.20, 9.0.14, 9.1.11, 10.0.8; Palo Alto Networks PAN-OS 9.1.11, 8.1.20, 9.0.14, 10.0.8. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2021-3062
- https://security.paloaltonetworks.com/CVE-2021-3062
Get alerted when CVE-2021-3062 or the next vulnerability affects your stack