What’s Vulnerable › Vulnerabilities
CVE-2021-3063: PAN-OS: Denial-of-Service (DoS) Vulnerability in GlobalProtect Portal and Gateway Interfaces
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-10 · updated 2026-06-17
- Weakness: CWE-755
Description
An improper handling of exceptional conditions vulnerability exists in Palo Alto Networks GlobalProtect portal and gateway interfaces that enables an unauthenticated network-based attacker to send specifically crafted traffic to a GlobalProtect interface that causes the service to stop responding. Repeated attempts to send this request result in denial of service to all PAN-OS services by restarting the device and putting it into maintenance mode. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.21; PAN-OS 9.0 versions earlier than PAN-OS 9.0.14-h4; PAN-OS 9.1 versions earlier than PAN-OS 9.1.11-h3; PAN-OS 10.0 versions earlier than PAN-OS 10.0.8-h4; PAN-OS 10.1 versions earlier than PAN-OS 10.1.3. Prisma Access customers are not impacted by this issue.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.21; from 9.0.0 through 9.0.14; from 9.1.0 through 9.1.11; from 10.0.0 through 10.0.8; from 10.1.0 before 10.1.3 — fixed in 8.1.21, 10.1.3
- Palo Alto Networks PAN-OS: from 8.1 before 8.1.21; from 9.0 before 9.0.14-h4; from 10.0 before 10.0.8-h4; from 10.1 before 10.1.3; from 9.1 before 9.1.11-h3 — fixed in 8.1.21, 9.0.14-h4, 10.0.8-h4, 10.1.3, 9.1.11-h3
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.21, 10.1.3; Palo Alto Networks PAN-OS 8.1.21, 9.0.14-h4, 10.0.8-h4, 10.1.3. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2021-3063
- https://security.paloaltonetworks.com/CVE-2021-3063
Get alerted when CVE-2021-3063 or the next vulnerability affects your stack