What’s Vulnerable › Vulnerabilities
CVE-2021-30638: An Information Disclosure due to insufficient input validation exists in Apache Tapestry 5.4.0 and later
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-27 · updated 2026-06-17
- Weakness: CWE-200
Description
Information Exposure vulnerability in context asset handling of Apache Tapestry allows an attacker to download files inside WEB-INF if using a specially-constructed URL. This was caused by an incomplete fix for CVE-2020-13953. This issue affects Apache Tapestry Apache Tapestry 5.4.0 version to Apache Tapestry 5.6.3; Apache Tapestry 5.7.0 version and Apache Tapestry 5.7.1.
Affected products
- Apache Software Foundation Apache Tapestry: from 5.4.0 before 5.6.4; from 5.7.0 before 5.7.2 — fixed in 5.6.4, 5.7.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Tapestry 5.6.4, 5.7.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/04/27/3
- https://lists.apache.org/thread.html/r37dab61fc7f7088d4311e7f995ef4117d58d86a675f0256caa6991eb%40%3Cusers.tapestry.apache.org%3E
- https://security.netapp.com/advisory/ntap-20210528-0004/
- https://www.zerodayinitiative.com/advisories/ZDI-21-491/
- http://www.openwall.com/lists/oss-security/2021/04/27/3
- https://lists.apache.org/thread.html/r37dab61fc7f7088d4311e7f995ef4117d58d86a675f0256caa6991eb%40%3Cusers.tapestry.apache.org%3E
- https://security.netapp.com/advisory/ntap-20210528-0004/
- https://www.zerodayinitiative.com/advisories/ZDI-21-491/
Get alerted when CVE-2021-30638 or the next vulnerability affects your stack