What’s Vulnerable › Vulnerabilities
CVE-2021-3064: PAN-OS: Memory Corruption Vulnerability in GlobalProtect Portal and Gateway Interfaces
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 20.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-10 · updated 2026-06-17
- Weakness: CWE-121
Description
A memory corruption vulnerability exists in Palo Alto Networks GlobalProtect portal and gateway interfaces that enables an unauthenticated network-based attacker to disrupt system processes and potentially execute arbitrary code with root privileges. The attacker must have network access to the GlobalProtect interface to exploit this issue. This issue impacts PAN-OS 8.1 versions earlier than PAN-OS 8.1.17. Prisma Access customers are not impacted by this issue.
Affected products
- Palo Alto Networks PAN-OS: from 8.1.0 before 8.1.17 — fixed in 8.1.17
- Palo Alto Networks PAN-OS: from 8.1 before 8.1.17 — fixed in 8.1.17
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 8.1.17; Palo Alto Networks PAN-OS 8.1.17. Check the vendor advisory for mitigations.
References
- https://security.paloaltonetworks.com/CVE-2021-3064
- https://security.paloaltonetworks.com/CVE-2021-3064
Get alerted when CVE-2021-3064 or the next vulnerability affects your stack