What’s Vulnerable › Vulnerabilities
CVE-2021-30648
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-30 · updated 2026-06-17
- Weakness: CWE-287
Description
The Symantec Advanced Secure Gateway (ASG) and ProxySG web management consoles are susceptible to an authentication bypass vulnerability. An unauthenticated attacker can execute arbitrary CLI commands, view/modify the appliance configuration and policy, and shutdown/restart the appliance.
Affected products
- Broadcom Symantec Advanced Secure Gateway 500-10 Firmware: from 6.6 before 6.7.4.17; from 6.7.5.0 before 6.7.5.12; from 7.2 before 7.2.7.2; from 7.3 before 7.3.3.3 — fixed in 6.7.4.17, 6.7.5.12, 7.2.7.2, 7.3.3.3
- Broadcom Symantec Advanced Secure Gateway S200-30 Firmware: from 6.6 before 6.7.4.17; from 6.7.5.0 before 6.7.5.12; from 7.2 before 7.2.7.2; from 7.3 before 7.3.3.3 — fixed in 6.7.4.17, 6.7.5.12, 7.2.7.2, 7.3.3.3
- Broadcom Symantec Advanced Secure Gateway S200-40 Firmware: from 6.6 before 6.7.4.17; from 6.7.5.0 before 6.7.5.12; from 7.2 before 7.2.7.2; from 7.3 before 7.3.3.3 — fixed in 6.7.4.17, 6.7.5.12, 7.2.7.2, 7.3.3.3
- Broadcom Symantec Advanced Secure Gateway S400-20 Firmware: from 6.6 before 6.7.4.17; from 6.7.5.0 before 6.7.5.12; from 7.2 before 7.2.7.2; from 7.3 before 7.3.3.3 — fixed in 6.7.4.17, 6.7.5.12, 7.2.7.2, 7.3.3.3
- Broadcom Symantec Advanced Secure Gateway S400-30 Firmware: from 6.6 before 6.7.4.17; from 6.7.5.0 before 6.7.5.12; from 7.2 before 7.2.7.2; from 7.3 before 7.3.3.3 — fixed in 6.7.4.17, 6.7.5.12, 7.2.7.2, 7.3.3.3
- Broadcom Symantec Advanced Secure Gateway S400-40 Firmware: from 6.6 before 6.7.4.17; from 6.7.5.0 before 6.7.5.12; from 7.2 before 7.2.7.2; from 7.3 before 7.3.3.3 — fixed in 6.7.4.17, 6.7.5.12, 7.2.7.2, 7.3.3.3
- Broadcom Symantec Advanced Secure Gateway S500-20 Firmware: from 6.6 before 6.7.4.17; from 6.7.5.0 before 6.7.5.12; from 7.2 before 7.2.7.2; from 7.3 before 7.3.3.3 — fixed in 6.7.4.17, 6.7.5.12, 7.2.7.2, 7.3.3.3
- Symantec Corporation ProxySG: from 6.5 before 6.5.10.16; from 6.6 before 6.6.5.19; from 6.7 before 6.7.5.12; from 7.2 before 7.2.7.2; from 7.3 before 7.3.3.3 — fixed in 6.5.10.16, 6.6.5.19, 6.7.5.12, 7.2.7.2, 7.3.3.3
How to fix
Upgrade to a fixed version: Broadcom Symantec Advanced Secure Gateway 500-10 Firmware 6.7.4.17, 6.7.5.12, 7.2.7.2, 7.3.3.3; Broadcom Symantec Advanced Secure Gateway S200-30 Firmware 6.7.4.17, 6.7.5.12, 7.2.7.2, 7.3.3.3; Broadcom Symantec Advanced Secure Gateway S200-40 Firmware 6.7.4.17, 6.7.5.12, 7.2.7.2, 7.3.3.3; Broadcom Symantec Advanced Secure Gateway S400-20 Firmware 6.7.4.17, 6.7.5.12, 7.2.7.2, 7.3.3.3; Broadcom Symantec Advanced Secure Gateway S400-30 Firmware 6.7.4.17, 6.7.5.12, 7.2.7.2, 7.3.3.3; Broadcom Symantec Advanced Secure Gateway S400-40 Firmware 6.7.4.17, 6.7.5.12, 7.2.7.2, 7.3.3.3; Broadcom Symantec Advanced Secure Gateway S500-20 Firmware 6.7.4.17, 6.7.5.12, 7.2.7.2, 7.3.3.3; Symantec Corporation ProxySG 6.5.10.16, 6.6.5.19, 6.7.5.12, 7.2.7.2. Check the vendor advisory for mitigations.
References
- https://support.broadcom.com/security-advisory/content/security-advisories/0/SYMSA18331
- https://support.broadcom.com/security-advisory/content/security-advisories/0/SYMSA18331
Get alerted when CVE-2021-30648 or the next vulnerability affects your stack