What’s Vulnerable › Vulnerabilities
CVE-2021-3100: Log4j hot patch package privilege escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-04-19 · updated 2026-06-17
- Weakness: CWE-250
Description
The Apache Log4j hotpatch package before log4j-cve-2021-44228-hotpatch-1.1-13 didn’t mimic the permissions of the JVM being patched, allowing it to escalate privileges.
Affected products
- Amazon Log4Jhotpatch: before 1.1-13 — fixed in 1.1-13
How to fix
Upgrade to a fixed version: Amazon Log4Jhotpatch 1.1-13. Check the vendor advisory for mitigations.
References
- https://alas.aws.amazon.com/AL2/ALAS-2021-1732.html
- https://alas.aws.amazon.com/ALAS-2021-1554.html
- https://unit42.paloaltonetworks.com/aws-log4shell-hot-patch-vulnerabilities
- https://alas.aws.amazon.com/AL2/ALAS-2021-1732.html
- https://alas.aws.amazon.com/ALAS-2021-1554.html
- https://unit42.paloaltonetworks.com/aws-log4shell-hot-patch-vulnerabilities
Get alerted when CVE-2021-3100 or the next vulnerability affects your stack