What’s Vulnerable › Vulnerabilities

CVE-2021-3114

Description

In Go before 1.14.14 and 1.15.x before 1.15.7, crypto/elliptic/p224.go can generate incorrect outputs, related to an underflow of the lowest limb during the final complete reduction in the P-224 field.

Affected products

How to fix

Upgrade to a fixed version: Go 1.14.14, 1.15.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-3114 or the next vulnerability affects your stack