What’s Vulnerable › Vulnerabilities

CVE-2021-3115

Description

Go before 1.14.14 and 1.15.x before 1.15.7 on Windows is vulnerable to Command Injection and remote code execution when using the "go get" command to fetch modules that make use of cgo (for example, cgo can execute a gcc program from an untrusted download).

Affected products

How to fix

Upgrade to a fixed version: Go 1.14.14, 1.15.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-3115 or the next vulnerability affects your stack