What’s Vulnerable › Vulnerabilities
CVE-2021-31153
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-27 · updated 2026-06-17
Description
please before 0.4 allows a local unprivileged attacker to gain knowledge about the existence of files or directories in privileged locations via the search_path function, the --check option, or the -d option.
Affected products
- Please Project Please: before 0.4 — fixed in 0.4
How to fix
Upgrade to a fixed version: Please Project Please 0.4. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/05/18/1
- https://gitlab.com/edneville/please/-/tree/master/src/bin
- http://www.openwall.com/lists/oss-security/2021/05/18/1
- https://gitlab.com/edneville/please/-/tree/master/src/bin
Get alerted when CVE-2021-31153 or the next vulnerability affects your stack