What’s Vulnerable › Vulnerabilities
CVE-2021-31154
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-27 · updated 2026-06-17
- Weakness: CWE-668
Description
pleaseedit in please before 0.4 uses predictable temporary filenames in /tmp and the target directory. This allows a local attacker to gain full root privileges by staging a symlink attack.
Affected products
- Pleaseedit Project Pleaseedit: before 0.4 — fixed in 0.4
How to fix
Upgrade to a fixed version: Pleaseedit Project Pleaseedit 0.4. Check the vendor advisory for mitigations.
References
- https://gitlab.com/edneville/please/-/tree/master/src/bin
- https://www.openwall.com/lists/oss-security/2021/05/18/1
- https://gitlab.com/edneville/please/-/tree/master/src/bin
- https://www.openwall.com/lists/oss-security/2021/05/18/1
Get alerted when CVE-2021-31154 or the next vulnerability affects your stack