What’s Vulnerable › Vulnerabilities
CVE-2021-31155
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-27 · updated 2026-06-17
- Weakness: CWE-732
Description
Failure to normalize the umask in please before 0.4 allows a local attacker to gain full root privileges if they are allowed to execute at least one command.
Affected products
- Umask Project Umask: before 0.4 — fixed in 0.4
How to fix
Upgrade to a fixed version: Umask Project Umask 0.4. Check the vendor advisory for mitigations.
References
- https://gitlab.com/edneville/please/-/tree/master/src/bin
- https://www.openwall.com/lists/oss-security/2021/05/18/1
- https://gitlab.com/edneville/please/-/tree/master/src/bin
- https://www.openwall.com/lists/oss-security/2021/05/18/1
Get alerted when CVE-2021-31155 or the next vulnerability affects your stack