What’s Vulnerable › Vulnerabilities
CVE-2021-3116
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-11 · updated 2026-06-17
- Weakness: CWE-697
Description
before_upstream_connection in AuthPlugin in http/proxy/auth.py in proxy.py before 2.3.1 accepts incorrect Proxy-Authorization header data because of a boolean confusion (and versus or).
Affected products
- Proxy.Py Project Proxy.Py: before 2.3.1 — fixed in 2.3.1
How to fix
Upgrade to a fixed version: Proxy.Py Project Proxy.Py 2.3.1. Check the vendor advisory for mitigations.
References
- https://cardaci.xyz/advisories/2021/01/10/proxy.py-2.3.0-broken-basic-authentication/
- https://github.com/abhinavsingh/proxy.py/pull/482/commits/9b00093288237f5073c403f2c4f62acfdfa8ed46
- https://pypi.org/project/proxy.py/2.3.1/#history
- https://cardaci.xyz/advisories/2021/01/10/proxy.py-2.3.0-broken-basic-authentication/
- https://github.com/abhinavsingh/proxy.py/pull/482/commits/9b00093288237f5073c403f2c4f62acfdfa8ed46
- https://pypi.org/project/proxy.py/2.3.1/#history
Get alerted when CVE-2021-3116 or the next vulnerability affects your stack