What’s Vulnerable › Vulnerabilities
CVE-2021-31164: Apache Unomi log injection
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-04 · updated 2026-06-17
- Weakness: CWE-93
Description
Apache Unomi prior to version 1.5.5 allows CRLF log injection because of the lack of escaping in the log statements.
Affected products
- Apache Software Foundation Apache Unomi: before 1.5.5 — fixed in 1.5.5
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Unomi 1.5.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-31164 or the next vulnerability affects your stack