What’s Vulnerable › Vulnerabilities
CVE-2021-3127
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-16 · updated 2026-06-17
- Weakness: CWE-755
Description
NATS Server 2.x before 2.2.0 and JWT library before 2.0.1 have Incorrect Access Control because Import Token bindings are mishandled.
Affected products
- nats-io nats-server: from 2.0.0 before 2.2.0 — fixed in 2.2.0
- Nats Jwt Library: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: nats-io nats-server 2.2.0; Nats Jwt Library 2.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-3127 or the next vulnerability affects your stack