What’s Vulnerable › Vulnerabilities
CVE-2021-31274
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-08 · updated 2026-06-17
- Weakness: CWE-79
Description
In LibreNMS < 21.3.0, a stored XSS vulnerability was identified in the API Access page due to insufficient sanitization of the $api->description variable. As a result, arbitrary Javascript code can get executed.
Affected products
- librenms: before 21.3.0 — fixed in 21.3.0
How to fix
Upgrade to a fixed version: librenms 21.3.0. Check the vendor advisory for mitigations.
References
- https://community.librenms.org/t/vulnerability-report-cross-site-scripting-xss-in-the-api-access-page/15431
- https://github.com/librenms/librenms
- https://github.com/librenms/librenms/pull/12739
- https://community.librenms.org/t/vulnerability-report-cross-site-scripting-xss-in-the-api-access-page/15431
- https://github.com/librenms/librenms
- https://github.com/librenms/librenms/pull/12739
Get alerted when CVE-2021-31274 or the next vulnerability affects your stack