What’s Vulnerable › Vulnerabilities
CVE-2021-31294
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-15 · updated 2026-06-17
- Weakness: CWE-617
Description
Redis before 6cbea7d allows a replica to cause an assertion failure in a primary server by sending a non-administrative command (specifically, a SET command). NOTE: this was fixed for Redis 6.2.x and 7.x in 2021. Versions before 6.2 were not intended to have safety guarantees related to this.
Affected products
- Redis: before 6.2.0 — fixed in 6.2.0
How to fix
Upgrade to a fixed version: Redis 6.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/commit/46f4ebbe842620f0976a36741a72482620aa4b48
- https://github.com/redis/redis/commit/6cbea7d29b5285692843bc1c351abba1a7ef326f
- https://github.com/redis/redis/issues/8712
- https://security.netapp.com/advisory/ntap-20230814-0007/
- https://github.com/redis/redis/commit/46f4ebbe842620f0976a36741a72482620aa4b48
- https://github.com/redis/redis/commit/6cbea7d29b5285692843bc1c351abba1a7ef326f
- https://github.com/redis/redis/issues/8712
- https://security.netapp.com/advisory/ntap-20230814-0007/
Get alerted when CVE-2021-31294 or the next vulnerability affects your stack