What’s Vulnerable › Vulnerabilities
CVE-2021-31402
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-15 · updated 2026-06-17
- Weakness: CWE-74
Description
The dio package 4.0.0 for Dart allows CRLF injection if the attacker controls the HTTP method string, a different vulnerability than CVE-2020-35669.
Affected products
- Flutterchina Dio: from 4.0.0 before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: Flutterchina Dio 5.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-31402 or the next vulnerability affects your stack