What’s Vulnerable › Vulnerabilities

CVE-2021-31407: Server classes and resources exposure in OSGi applications using Vaadin 12-14 and 19

Description

Vulnerability in OSGi integration in com.vaadin:flow-server versions 1.2.0 through 2.4.7 (Vaadin 12.0.0 through 14.4.9), and 6.0.0 through 6.0.1 (Vaadin 19.0.0) allows attacker to access application classes and resources on the server via crafted HTTP request.

Affected products

How to fix

Upgrade to a fixed version: vaadin flow 2.4.8, 6.0.2; Vaadin 14.4.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-31407 or the next vulnerability affects your stack