What’s Vulnerable › Vulnerabilities

CVE-2021-31411: Insecure temporary directory usage in frontend build functionality of Vaadin 14 and 15-19

Description

Insecure temporary directory usage in frontend build functionality of com.vaadin:flow-server versions 2.0.9 through 2.5.2 (Vaadin 14.0.3 through Vaadin 14.5.2), 3.0 prior to 6.0 (Vaadin 15 prior to 19), and 6.0.0 through 6.0.5 (Vaadin 19.0.0 through 19.0.4) allows local users to inject malicious code into frontend resources during application rebuilds.

Affected products

How to fix

Upgrade to a fixed version: vaadin flow 2.5.3; Vaadin 14.5.3, 19.0.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-31411 or the next vulnerability affects your stack