What’s Vulnerable › Vulnerabilities
CVE-2021-3151
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-02-27 · updated 2026-06-17
- Weakness: CWE-79
Description
i-doit before 1.16.0 is affected by Stored Cross-Site Scripting (XSS) issues that could allow remote authenticated attackers to inject arbitrary web script or HTML via C__MONITORING__CONFIG__TITLE, SM2__C__MONITORING__CONFIG__TITLE, C__MONITORING__CONFIG__PATH, SM2__C__MONITORING__CONFIG__PATH, C__MONITORING__CONFIG__ADDRESS, or SM2__C__MONITORING__CONFIG__ADDRESS.
Affected products
- I-Doit doit CMDB: before 1.16.0 — fixed in 1.16.0
How to fix
Upgrade to a fixed version: I-Doit doit CMDB 1.16.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/162815/i-doit-1.15.2-Cross-Site-Scripting.html
- https://www.i-doit.org/news/
- https://www.wizlynxgroup.com/security-research-advisories/vuln/WLX-2020-056
- http://packetstormsecurity.com/files/162815/i-doit-1.15.2-Cross-Site-Scripting.html
- https://www.i-doit.org/news/
- https://www.wizlynxgroup.com/security-research-advisories/vuln/WLX-2020-056
Get alerted when CVE-2021-3151 or the next vulnerability affects your stack