What’s Vulnerable › Vulnerabilities
CVE-2021-3152
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-26 · updated 2026-06-17
- Weakness: CWE-22
Description
Home Assistant before 2021.1.3 does not have a protection layer that can help to prevent directory-traversal attacks against custom integrations. NOTE: the vendor's perspective is that the vulnerability itself is in custom integrations written by third parties, not in Home Assistant; however, Home Assistant does have a security update that is worthwhile in addressing this situation
Affected products
- Home-Assistant: before 2021.1.3 — fixed in 2021.1.3
How to fix
Upgrade to a fixed version: Home-Assistant 2021.1.3. Check the vendor advisory for mitigations.
References
- https://www.home-assistant.io/blog/2021/01/14/security-bulletin/
- https://www.home-assistant.io/blog/2021/01/22/security-disclosure/
- https://www.home-assistant.io/blog/2021/01/14/security-bulletin/
- https://www.home-assistant.io/blog/2021/01/22/security-disclosure/
Get alerted when CVE-2021-3152 or the next vulnerability affects your stack