What’s Vulnerable › Vulnerabilities
CVE-2021-31522: Apache Kylin unsafe class loading
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-06 · updated 2026-06-17
- Weakness: CWE-470
Description
Kylin can receive user input and load any class through Class.forName(...). This issue affects Apache Kylin 2 version 2.6.6 and prior versions; Apache Kylin 3 version 3.1.2 and prior versions; Apache Kylin 4 version 4.0.0 and prior versions.
Affected products
- Apache Software Foundation Apache Kylin: from 2.0.0 through 2.6.6; from 3.0.0 before 3.1.3; 4.0.0, 4.0.0-alpha, 4.0.0-beta — fixed in 3.1.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kylin 3.1.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/06/4
- https://lists.apache.org/thread/hh5crx3yr701zd8wtpqo1mww2rlkvznw
- http://www.openwall.com/lists/oss-security/2022/01/06/4
- https://lists.apache.org/thread/hh5crx3yr701zd8wtpqo1mww2rlkvznw
Get alerted when CVE-2021-31522 or the next vulnerability affects your stack