What’s Vulnerable › Vulnerabilities
CVE-2021-31671
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-27 · updated 2026-06-17
- Weakness: CWE-319
Description
pgsync before 0.6.7 is affected by Information Disclosure of sensitive information. Syncing the schema with the --schema-first and --schema-only options is mishandled. For example, the sslmode connection parameter may be lost, which means that SSL would not be used.
Affected products
- Pgsync Project Pgsync: before 0.6.7 — fixed in 0.6.7
How to fix
Upgrade to a fixed version: Pgsync Project Pgsync 0.6.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-31671 or the next vulnerability affects your stack