What’s Vulnerable › Vulnerabilities
CVE-2021-31796
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-02 · updated 2026-06-17
- Weakness: CWE-327
Description
An inadequate encryption vulnerability discovered in CyberArk Credential Provider before 12.1 may lead to Information Disclosure. An attacker may realistically have enough information that the number of possible keys (for a credential file) is only one, and the number is usually not higher than 2^36.
Affected products
- CyberArk Credential Provider: before 12.1 — fixed in 12.1
How to fix
Upgrade to a fixed version: CyberArk Credential Provider 12.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/164023/CyberArk-Credential-File-Insufficient-Effective-Key-Space.html
- http://seclists.org/fulldisclosure/2021/Sep/1
- https://korelogic.com/Resources/Advisories/KL-001-2021-008.txt
- https://www.cyberark.com/resources/blog
- http://packetstormsecurity.com/files/164023/CyberArk-Credential-File-Insufficient-Effective-Key-Space.html
- http://seclists.org/fulldisclosure/2021/Sep/1
- https://korelogic.com/Resources/Advisories/KL-001-2021-008.txt
- https://www.cyberark.com/resources/blog
Get alerted when CVE-2021-31796 or the next vulnerability affects your stack