What’s Vulnerable › Vulnerabilities
CVE-2021-31808
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-27 · updated 2026-06-17
- Weakness: CWE-190
Description
An issue was discovered in Squid before 4.15 and 5.x before 5.0.6. Due to an input-validation bug, it is vulnerable to a Denial of Service attack (against all clients using the proxy). A client sends an HTTP Range request to trigger this.
Affected products
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 33, 34
- Cloud Manager: all versions
- Squid: before 4.15; from 5.0 before 5.0.6 — fixed in 4.15, 5.0.6
How to fix
Upgrade to a fixed version: Squid 4.15, 5.0.6. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2023/Oct/14
- http://www.openwall.com/lists/oss-security/2023/10/11/3
- http://www.squid-cache.org/Versions/v4/changesets/squid-4-e7cf864f938f24eea8af0692c04d16790983c823.patch
- https://github.com/squid-cache/squid/security/advisories/GHSA-pxwq-f3qr-w2xf
- https://lists.debian.org/debian-lts-announce/2021/06/msg00014.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LSQ3U54ZCNXR44QRPW3AV2VCS6K3TKCF/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/T4EPIWUZDJAXADDHVOPKRBTQHPBR6H66/
- https://security.netapp.com/advisory/ntap-20210716-0007/
- https://www.debian.org/security/2021/dsa-4924
- http://seclists.org/fulldisclosure/2023/Oct/14
- http://www.openwall.com/lists/oss-security/2023/10/11/3
- http://www.squid-cache.org/Versions/v4/changesets/squid-4-e7cf864f938f24eea8af0692c04d16790983c823.patch
Get alerted when CVE-2021-31808 or the next vulnerability affects your stack