What’s Vulnerable › Vulnerabilities
CVE-2021-31818
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-17 · updated 2026-06-17
- Weakness: CWE-89
Description
Affected versions of Octopus Server are prone to an authenticated SQL injection vulnerability in the Events REST API because user supplied data in the API request isn’t parameterised correctly. Exploiting this vulnerability could allow unauthorised access to database tables.
Affected products
- Octopus Server: from 2018.9.17 before 2018.13.0; from 2020.0.0 before 2020.6.0; from 2020.6.0 before 2020.6.5146; from 2021.1.0 before 2021.1.7316 — fixed in 2018.13.0, 2020.6.0, 2020.6.5146, 2021.1.7316
How to fix
Upgrade to a fixed version: Octopus Server 2018.13.0, 2020.6.0, 2020.6.5146, 2021.1.7316. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/adv/2021-04---SQL-Injection-in-the-Events-REST-API-%28CVE-2021-31818%29.2013233248.html
- https://advisories.octopus.com/adv/2021-04---SQL-Injection-in-the-Events-REST-API-%28CVE-2021-31818%29.2013233248.html
Get alerted when CVE-2021-31818 or the next vulnerability affects your stack